Commit 3568586b authored by Kevin Liu's avatar Kevin Liu

Remove sharp from responsive-loader

parent 703ad598
Pipeline #2024 failed with stages
in 179 minutes and 36 seconds
......@@ -52,7 +52,6 @@ const config = {
{
loader: "responsive-loader",
options: {
adapter: require("responsive-loader/sharp"),
name: "static/media/[hash]-[width].[ext]"
}
},
......
......@@ -130,7 +130,6 @@
"request-promise": "^4.2.6",
"requirejs": "^2.3.6",
"schema-dts": "^0.6.0",
"sharp": "^0.26.1",
"styled-components": "^5.2.0",
"three": "^0.114.0",
"true-myth": "^2.2.8",
......
import React from "react";
const logoIconWebp = require("../../images/logo-icon.png?format=webp&sizes[]=50,sizes[]=100,sizes[]=150,sizes[]=200");
const logoIcon = require("../../images/logo-icon.png?sizes[]=50,sizes[]=100,sizes[]=150,sizes[]=200");
export default () => (
<div className="logo" key="logo">
<span>
<picture>
<source type="image/webp" {...logoIconWebp} />
<source type="image/png" {...logoIcon} />
<img {...logoIcon} alt="logo" height="50" width="50" />
</picture>
......
......@@ -16907,11 +16907,6 @@ node-addon-api@^3.0.0:
resolved "https://registry.yarnpkg.com/node-addon-api/-/node-addon-api-3.0.0.tgz#812446a1001a54f71663bed188314bba07e09247"
integrity sha512-sSHCgWfJ+Lui/u+0msF3oyCgvdkhxDbkCS6Q8uiJquzOimkJBvX6hl5aSSA7DR1XbMpdM8r7phjcF63sF4rkKg==
node-addon-api@^3.0.2:
version "3.0.2"
resolved "https://registry.yarnpkg.com/node-addon-api/-/node-addon-api-3.0.2.tgz#04bc7b83fd845ba785bb6eae25bc857e1ef75681"
integrity sha512-+D4s2HCnxPd5PjjI0STKwncjXTUKKqm74MDMz9OPXavjsGmjkvwgLtA5yoxJUdmpj52+2u+RrXgPipahKczMKg==
node-fetch-npm@^2.0.2:
version "2.0.2"
resolved "https://registry.yarnpkg.com/node-fetch-npm/-/node-fetch-npm-2.0.2.tgz#7258c9046182dca345b4208eda918daf33697ff7"
......@@ -19064,7 +19059,7 @@ preact@^8.2.7:
version "8.3.1"
resolved "https://registry.yarnpkg.com/preact/-/preact-8.3.1.tgz#ed34f79d09edc5efd32a378a3416ef5dc531e3ac"
prebuild-install@^5.3.4, prebuild-install@^5.3.5:
prebuild-install@^5.3.4:
version "5.3.5"
resolved "https://registry.yarnpkg.com/prebuild-install/-/prebuild-install-5.3.5.tgz#e7e71e425298785ea9d22d4f958dbaccf8bb0e1b"
integrity sha512-YmMO7dph9CYKi5IR/BzjOJlRzpxGGVo1EsLSUZ0mt/Mq0HWZIHOKHHcHdT69yG54C9m6i45GpItwRHpk0Py7Uw==
......@@ -21851,21 +21846,6 @@ sharp@^0.25.2:
tar "^6.0.2"
tunnel-agent "^0.6.0"
sharp@^0.26.1:
version "0.26.1"
resolved "https://registry.yarnpkg.com/sharp/-/sharp-0.26.1.tgz#084e3447ba17f1baf3e3f2e08305ed7aec236ce9"
integrity sha512-9MhwS4ys8pnwBH7MtnBdLzUv+cb24QC4xbzzQL6A+1MQ4Se2V6oPHEX8TIGIZUPRKi6S1kJPVNzt/Xqqp6/H3Q==
dependencies:
color "^3.1.2"
detect-libc "^1.0.3"
node-addon-api "^3.0.2"
npmlog "^4.1.2"
prebuild-install "^5.3.5"
semver "^7.3.2"
simple-get "^4.0.0"
tar-fs "^2.1.0"
tunnel-agent "^0.6.0"
shebang-command@^1.2.0:
version "1.2.0"
resolved "https://registry.yarnpkg.com/shebang-command/-/shebang-command-1.2.0.tgz#44aac65b695b03398968c39f363fee5deafdf1ea"
......@@ -22878,16 +22858,6 @@ tar-fs@^2.0.0:
pump "^3.0.0"
tar-stream "^2.0.0"
tar-fs@^2.1.0:
version "2.1.0"
resolved "https://registry.yarnpkg.com/tar-fs/-/tar-fs-2.1.0.tgz#d1cdd121ab465ee0eb9ccde2d35049d3f3daf0d5"
integrity sha512-9uW5iDvrIMCVpvasdFHW0wJPez0K4JnMZtsuIeDI7HyMGJNxmDZDOCQROr7lXyS+iL/QMpj07qcjGYTSdRFXUg==
dependencies:
chownr "^1.1.1"
mkdirp-classic "^0.5.2"
pump "^3.0.0"
tar-stream "^2.0.0"
tar-stream@^1.5.2:
version "1.6.2"
resolved "https://registry.yarnpkg.com/tar-stream/-/tar-stream-1.6.2.tgz#8ea55dab37972253d9a9af90fdcd559ae435c555"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment